Free Trial

Safari Books Online is a digital library providing on-demand subscription access to thousands of learning resources.

  • Create BookmarkCreate Bookmark
  • Create Note or TagCreate Note or Tag
  • PrintPrint
Share this Page URL
Help

Chapter 3. Implementing a Scalable Multi... > Configuration Example: Single-Area O...

Configuration Example: Single-Area OSPF

Figure 3-2 shows the network topology for the configuration that follows, which demonstrates how to configure single-area OSPF using the commands covered in this chapter.

Figure 3-2. Network Topology for Single-Area OSPF Configuration


Austin Router

Router>enable

Moves to privileged mode.
Router#configure terminal

Moves to global configuration mode.
Router(config)#hostname Austin

Sets the hostname.
Austin(config)#interface fastethernet 0/0

Moves to interface configuration mode.
Austin(config-if)#ip address 172.16.10.1 255.255.255.0

Assigns an IP address and netmask.
Austin(config-if)#no shutdown

Enables the interface.
Austin(config-if)#interface serial 0/0/0

Moves to interface configuration mode.
Austin(config-if)#ip address 172.16.20.1 255.255.255.252

Assigns an IP address and netmask.
Austin(config-if)#clock rate 56000

Sets a clock rate on this interface. A DCE cable must be plugged in to this side.
Austin(config-if)#no shutdown

Enables the interface.
Austin(config-if)#exit

Returns to global configuration mode.
Austin(config)#router ospf 1

Starts OSPF process 1.
Austin(config-router)#network 172.16.10.0 0.0.0.255 area 0

Read this line to say, “Any interface with an address of 172.16.10.x is to be put into area 0.”
Austin(config-router)#network 172.16.20.0 0.0.0.255 area 0

Read this line to say, “Any interface with an address of 172.16.20.x is to be put into area 0.
Austin(config-router)#<ctrl> z

Returns to privileged mode.
Austin#copy running-config startup-config

Saves the configuration to NVRAM.


Houston Router

Router>enable

Moves to privileged mode.
Router#configure terminal

Moves to global configuration mode.
Router(config)#hostname Houston

Sets the hostname.
Houston(config)#interface fastethernet 0/0

Moves to interface configuration mode.
Houston(config-if)#ip address 172.16.30.1 255.255.255.0

Assigns an IP address and netmask.
Houston(config-if)#no shutdown

Enables the interface.
Houston(config-if)#interface serial 0/0/0

Moves to interface configuration mode.
Houston(config-if)#ip address 172.16.40.1 255.255.255.252

Assigns an IP address and netmask.
Houston(config-if)#clock rate 56000

Sets a clock rate on this interface. A DCE cable must be plugged in to this side.
Houston(config-if)#no shutdown

Enables the interface.
Houston(config)#interface serial 0/0/1

Moves to interface configuration mode.
Houston(config-if)#ip address 172.16.20.2 255.255.255.252

Assigns an IP address and netmask.
Houston(config-if)#no shutdown

Enables the interface.
Houston(config-if)#exit

Returns to global configuration mode.
Houston(config)#router ospf 1

Starts OSPF process 1.
Houston(config-router)#network 172.16.0.0 0.0.255.255 area 0

Read this line to say, “Any interface with an address of 172.16.x.x is to be put into area 0.” One statement will now advertise all three interfaces.
Houston(config-router)#<ctrl> z

Returns to privileged mode.
Houston#copy running-config startup-config

Saves the configuration to NVRAM.


Galveston Router

Router>enable

Moves to privileged mode.
Router#configure terminal

Moves to global configuration mode.
Router(config)#hostname Galveston

Sets the hostname.
Galveston(config)#interface fastethernet 0/0

Moves to interface configuration mode.
Galveston(config-if)#ip address 172.16.50.1 255.255.255.0

Assigns an IP address and netmask.
Galveston(config-if)#no shutdown

Enables the interface.
Galveston(config-if)#interface serial 0/0/1

Moves to interface configuration mode.
Galveston(config-if)#ip address 172.16.40.2 255.255.255.252

Assigns an IP address and netmask.
Galveston(config-if)#no shutdown

Enables the interface.
Galveston(config-if)#exit

Returns to global configuration mode.
Galveston(config)#router ospf 1

Starts OSPF process 1.
Galveston(config-router)#network 172.16.40.2 0.0.0.0 area 0

Any interface with an exact address of 172.16.40.2 is to be put into area 0. This is the most precise way to place an exact address into the OSPF routing process.
Galveston(config-router)#network 172.16.50.1 0.0.0.0 area 0

Read this line to say, “Any interface with an exact address of 172.16.50.1 is to be put into area 0.”
Galveston(config-router)#<ctrl> z

Returns to privileged mode.
Galveston#copy running-config startup-config

Saves the configuration to NVRAM.


  • Safari Books Online
  • Create BookmarkCreate Bookmark
  • Create Note or TagCreate Note or Tag
  • PrintPrint